李辉

2018年12月8日

如果你是 Windows + Python 2.7 用户,可以升级 python-dotenv 至三天前发布的 0.10.0 版本,这样可以解决运行 Flask 程序出现的 TypeError: environment can only contain strings 异常(#101 最终被合并了)。

另外,最近所有示例程序完成了一次全面的更新(多个 bug 修复,项目依赖升级)。请按照前言“使用示例程序”部分更新所有源码仓库,然后重新执行一次 pipenv install,这会一并更新 python-dotenv 版本。如果不方便访问 GitHub,可以点击链接(http://helloflask.com/downloads/helloflask-projects.zip)下载最新的全部源码打包文件。

几个月过去,这个问题终于有了合理的解决方案。

说说你的想法吧!

邮箱不会被公开,必填项已用*标出。

*